hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zhijie Shen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-1931) YARN-1824 in 2.4 broke compatibility with previous releases
Date Fri, 11 Apr 2014 16:36:16 GMT

    [ https://issues.apache.org/jira/browse/YARN-1931?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13966742#comment-13966742
] 

Zhijie Shen commented on YARN-1931:
-----------------------------------

Right, we saw the same problem recently.

bq. I'm also a bit confused by this api marking. Its marked as private but it claims to be
utilities for applications.

It seems to be better to mark Apps as \@Public. MR, as an application framework, has used
it. Spark is using it, and I think there should be other applications as well.





> YARN-1824 in 2.4 broke compatibility with previous releases
> -----------------------------------------------------------
>
>                 Key: YARN-1931
>                 URL: https://issues.apache.org/jira/browse/YARN-1931
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: applications
>    Affects Versions: 2.4.0
>            Reporter: Thomas Graves
>            Priority: Blocker
>
> YARN-1824 broke compatibility with previous 2.x releases by changes the API's in org.apache.hadoop.yarn.util.Apps.{setEnvFromInputString,addToEnvironment}
 The old api should be added back in.
> This affects any ApplicationMasters who were using this api.  It also breaks previously
built MapReduce libraries from working with the new Yarn release as MR uses this api. 



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message