hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karthik Kambatla (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-1696) Document RM HA
Date Thu, 27 Mar 2014 02:09:17 GMT

    [ https://issues.apache.org/jira/browse/YARN-1696?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13948769#comment-13948769

Karthik Kambatla commented on YARN-1696:

bq. It's late, but after seeing the document, I think we should rename "yarn.resourcemanager.ha."
configs to be "yarn.resourcemanager.failover."
I would prefer leaving it as ha. I understand your intention that this is primarily failover
and not HA in the true sense of the word. I think these configs would apply to Active/Active
and true HA, whenever we end up implementing that. Before naming the configs, I did spend
sometime thinking about it. Also vaguely remember a conversation with Bikas about future true
HA possibilities.  

> Document RM HA
> --------------
>                 Key: YARN-1696
>                 URL: https://issues.apache.org/jira/browse/YARN-1696
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: resourcemanager
>    Affects Versions: 2.3.0
>            Reporter: Karthik Kambatla
>            Assignee: Karthik Kambatla
>            Priority: Blocker
>         Attachments: YARN-1696.2.patch, yarn-1696-1.patch
> Add documentation for RM HA. Marking this a blocker for 2.4 as this is required to call
RM HA Stable and ready for public consumption. 

This message was sent by Atlassian JIRA

View raw message