hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hitesh Shah (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-1758) MiniYARNCluster broken post YARN-1666
Date Tue, 25 Feb 2014 18:40:20 GMT

    [ https://issues.apache.org/jira/browse/YARN-1758?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13911863#comment-13911863
] 

Hitesh Shah commented on YARN-1758:
-----------------------------------

[~ozawa] The problem is due to the loading of yarn-site.xml and other resources in ResourceManager::serviceInit().
It does not show up in yarn tests as the yarn-site.xml is added into yarn-resourcemanager-tests.jar
I believe. However, for all downstream projects, they depend on hadoop-yarn-server-tests-tests.jar
for MiniYarnCluster which itself does not have the necessary yarn-site, etc.

I think the fix might be as simple as moving the required configs from hadoop-yarn-server-resourcemanager/src/test/resources/
to hadoop-yarn-server-tests/src/test/resources/ so that the required confs are bundled in
the same tests jar.

> MiniYARNCluster broken post YARN-1666
> -------------------------------------
>
>                 Key: YARN-1758
>                 URL: https://issues.apache.org/jira/browse/YARN-1758
>             Project: Hadoop YARN
>          Issue Type: Bug
>            Reporter: Hitesh Shah
>
> NPE seen when trying to use MiniYARNCluster



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message