hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Varun Vasudev (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-1713) Implement getnewapplication and submitapp as part of RM web service
Date Thu, 27 Feb 2014 12:00:25 GMT

    [ https://issues.apache.org/jira/browse/YARN-1713?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13914437#comment-13914437
] 

Varun Vasudev commented on YARN-1713:
-------------------------------------

> The following piece can be incorporated into the above ApplicationSubmissionContext.newInstance(
        appContext.setKeepContainersAcrossApplicationAttempts(
          newApp.isKeepContainers());
Fixed

> hasQueueAccess is not used anywhere? I think we can just use hasAccess() in all the places
and parameterize ApplicationAccessType and ApplicationAccessType?
hasAccess returns true only if the user has app and queue access. For killing an app, we only
need app access. Maybe we can change hasAcess to use hasAppAccess and hasQueueAccess instead?

> Rename AppSubmissionInfo to AppSubmissionContextInfo ?, similarly name="appsubmission"
-> “appsubmissioncontext”. Similarly, ContainerLaunchInfo -> ContainerLaunchContextInfo
Fixed

> AppSubmissionInfo: we can initialize cancelTokensWhenComplete to true, keepContainers
to false
Fixed

> Also , we can replace the "Location" with constant HttpHeaders.LOCATION
Fixed



> Implement getnewapplication and submitapp as part of RM web service
> -------------------------------------------------------------------
>
>                 Key: YARN-1713
>                 URL: https://issues.apache.org/jira/browse/YARN-1713
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Varun Vasudev
>            Assignee: Varun Vasudev
>         Attachments: apache-yarn-1713.3.patch, apache-yarn-1713.4.patch, apache-yarn-1713.5.patch,
apache-yarn-1713.cumulative.2.patch, apache-yarn-1713.cumulative.3.patch, apache-yarn-1713.cumulative.4.patch,
apache-yarn-1713.cumulative.patch, apache-yarn-1713.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message