hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karthik Kambatla (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-1499) Fair Scheduler changes for moving apps between queues
Date Tue, 04 Feb 2014 01:35:06 GMT

    [ https://issues.apache.org/jira/browse/YARN-1499?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13890257#comment-13890257

Karthik Kambatla commented on YARN-1499:

The patch mostly looks good to me. Minor comments: 
# FairScheduler#findLeastCommonAncestorQueue - can we rename this to make it clearer - lowestCommonAncestor
or firstCommonAncestor. Should update the variable also accordingly. 
# FairScheduler#findLeastCommonAncestorQueue - I am not particular about this, but iterating
through parents of one queue and checking if the other queue has this parent as part of its
name might be easier to understand. 
# Few lines in the patch are longer than 80 chars. 
# FairScheduler#executeMove - we should make either make this synchronized or clearly document
that the caller should hold a lock on FairScheduler

> Fair Scheduler changes for moving apps between queues
> -----------------------------------------------------
>                 Key: YARN-1499
>                 URL: https://issues.apache.org/jira/browse/YARN-1499
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: scheduler
>            Reporter: Sandy Ryza
>            Assignee: Sandy Ryza
>         Attachments: YARN-1499-1.patch, YARN-1499.patch

This message was sent by Atlassian JIRA

View raw message