hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Haohui Mai (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-1600) RM does not startup when security is enabled without spnego configured
Date Wed, 15 Jan 2014 20:59:22 GMT

    [ https://issues.apache.org/jira/browse/YARN-1600?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13872586#comment-13872586
] 

Haohui Mai commented on YARN-1600:
----------------------------------

I think at least in the short term that the earlier approach of YARN-1463 could work. We'll
need to revisit the issue of supporting SPNEGO and third-party HTTP authentication in the
longer term.

> RM does not startup when security is enabled without spnego configured
> ----------------------------------------------------------------------
>
>                 Key: YARN-1600
>                 URL: https://issues.apache.org/jira/browse/YARN-1600
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: resourcemanager
>    Affects Versions: 2.4.0
>            Reporter: Jason Lowe
>            Priority: Blocker
>
> We have a custom auth filter in front of our various UI pages that handles user authentication.
 However currently the RM assumes that if security is enabled then the user must have configured
spnego as well for the RM web pages which is not true in our case.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message