hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karthik Kambatla (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-1568) Rename clusterid to clusterId in ActiveRMInfoProto
Date Thu, 09 Jan 2014 03:59:06 GMT

    [ https://issues.apache.org/jira/browse/YARN-1568?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13866289#comment-13866289

Karthik Kambatla commented on YARN-1568:

bq. our convention is to mark all fields as optional and handle any 'required' nature in code.
I see. That is why I saw some other protos have optional fields in them even though they were
required by the protocols. I am just curious - is there a good reason for adopting this convention?
Adding a new proto with required fileds is definitely not incompatible, right? 

> Rename clusterid to clusterId in ActiveRMInfoProto 
> ---------------------------------------------------
>                 Key: YARN-1568
>                 URL: https://issues.apache.org/jira/browse/YARN-1568
>             Project: Hadoop YARN
>          Issue Type: Task
>          Components: resourcemanager
>    Affects Versions: 2.4.0
>            Reporter: Karthik Kambatla
>            Assignee: Karthik Kambatla
>            Priority: Trivial
>             Fix For: 2.4.0
>         Attachments: yarn-1568-1.patch, yarn-1568-1.patch
> YARN-1029 introduces ActiveRMInfoProto - just realized it defines a field clusterid,
which is inconsistent with other fields. Better to fix it immediately than leave the inconsistency.

This message was sent by Atlassian JIRA

View raw message