hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vinod Kumar Vavilapalli (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-1568) Rename clusterid to clusterId in ActiveRMInfoProto
Date Thu, 09 Jan 2014 03:20:52 GMT

    [ https://issues.apache.org/jira/browse/YARN-1568?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13866254#comment-13866254
] 

Vinod Kumar Vavilapalli commented on YARN-1568:
-----------------------------------------------

Hey. I missed this before, but our convention is to mark all fields as optional and handle
any 'required' nature in code. Can we change this proto to also be like that?

> Rename clusterid to clusterId in ActiveRMInfoProto 
> ---------------------------------------------------
>
>                 Key: YARN-1568
>                 URL: https://issues.apache.org/jira/browse/YARN-1568
>             Project: Hadoop YARN
>          Issue Type: Task
>          Components: resourcemanager
>    Affects Versions: 2.4.0
>            Reporter: Karthik Kambatla
>            Assignee: Karthik Kambatla
>            Priority: Trivial
>             Fix For: 2.4.0
>
>         Attachments: yarn-1568-1.patch, yarn-1568-1.patch
>
>
> YARN-1029 introduces ActiveRMInfoProto - just realized it defines a field clusterid,
which is inconsistent with other fields. Better to fix it immediately than leave the inconsistency.




--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message