hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vinod Kumar Vavilapalli (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-1139) [Umbrella] Convert all RM components to Services
Date Fri, 06 Dec 2013 20:37:37 GMT

    [ https://issues.apache.org/jira/browse/YARN-1139?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13841672#comment-13841672
] 

Vinod Kumar Vavilapalli commented on YARN-1139:
-----------------------------------------------

bq. My primary rationale for this JIRA was to reduce the time to transition to Active in the
long-term, or to support a "warmer" Standby mode. Converting all the components to services
is not absolutely required for that.
Then let's not do more than what is necessary. We can keep these JIRAs around and tackle them
when it's needed, in the correct way. For now, are we good with the conversion of some always-on
vs active services?

bq. There could be a single SecretManagerService that handles the lifecycle of all YARN-related
*SecretManagers.
If converting them to services is really necessary, that is the same approach that I was thinking
about. As I see on YARN-1172, we are adding a lot of boiler plate code for not a whole lot
of benefits.



> [Umbrella] Convert all RM components to Services
> ------------------------------------------------
>
>                 Key: YARN-1139
>                 URL: https://issues.apache.org/jira/browse/YARN-1139
>             Project: Hadoop YARN
>          Issue Type: Improvement
>          Components: resourcemanager
>    Affects Versions: 2.1.0-beta
>            Reporter: Karthik Kambatla
>            Assignee: Tsuyoshi OZAWA
>
> Some of the RM components - state store, scheduler etc. are not services. Converting
them to services goes well with the "Always On" and "Active" service separation proposed on
YARN-1098.
> Given that some of them already have start(), stop() methods, it should not be too hard
to convert them to services.
> That would also be a cleaner way of addressing YARN-1125.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message