hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zhijie Shen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-954) [YARN-321] History Service should create the webUI and wire it to HistoryStorage
Date Mon, 12 Aug 2013 17:18:49 GMT

    [ https://issues.apache.org/jira/browse/YARN-954?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13737062#comment-13737062
] 

Zhijie Shen commented on YARN-954:
----------------------------------

Thanks [~devaraj.k] for your work. I've some comments on latest patch.

Is it better to call it "Attempt ID"?
{code}
+    _("Attempt Number:", applicationAttempt.getApplicationAttemptId()).
{code}

Shall we make trackingURL an url as well?
{code}
+      td(attemptData.getTrackingURL()).
{code}

Is it a bit ambiguous that the app.id param can be either application id or appattempt id?
{code}
+    String id = $(YarnWebParams.APPLICATION_ID);
...
+      if (id.startsWith(ConverterUtils.APPLICATION_PREFIX)) {
...
+      else {
...
{code}
Should we no allow appattempt id here? Or add
{code}
+    route(pajoin("/containers", YarnWebParams.APPLICATION_ATTEMPT_ID),
+        ApplicationHistoryController.class, "containersWithAttemptId");
{code}

The following names seem to be wrong:
{code}
+        th().input("search_init").$type(InputType.text).$name("start_time").$value("Container
ID")._()._().
+        th().input("search_init").$type(InputType.text).$name("finish_time").$value("Allocated
Resource")._()._().
+        th().input("search_init").$type(InputType.text).$name("start_time").$value("Assigned
Node")._()._().
+        th().input("search_init").$type(InputType.text).$name("start_time").$value("Priority")._()._().
+        th().input("search_init").$type(InputType.text).$name("start_time").$value("Start
Time")._()._().
+        th().input("search_init").$type(InputType.text).$name("start_time").$value("Finish
Time")._()._().
+        th().input("search_init").$type(InputType.text).$name("start_time").$value("Diagnostics")._()._().
+        th().input("search_init").$type(InputType.text).$name("start_time").$value("Final
Container Status")._()._()
{code}

Moreover, should attempt page have the field of the appId of the application that the attempt
belongs to? Similarly should the container page have the field of the attemptId and the appId
of the attempt and the application that the container belongs to? In addition, it would be
good the field is an url to link back to the owner object's page. Thoughts?
                
> [YARN-321] History Service should create the webUI and wire it to HistoryStorage
> --------------------------------------------------------------------------------
>
>                 Key: YARN-954
>                 URL: https://issues.apache.org/jira/browse/YARN-954
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Vinod Kumar Vavilapalli
>            Assignee: Devaraj K
>         Attachments: YARN-954-v0.patch, YARN-954-v1.patch
>
>


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message