hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karthik Kambatla (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-939) Rename ContainerManagerImpl to ContainerManagementImpl
Date Mon, 29 Jul 2013 21:33:49 GMT

    [ https://issues.apache.org/jira/browse/YARN-939?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13723005#comment-13723005

Karthik Kambatla commented on YARN-939:

I think we should leave ContainerManager as is. The ContainerManagementProtocol is implemented
by both ContainerManager and NodeManager. Also, there are several references to ContainerManager.

If we still decide to rename it, we should call it ContainerManagementService.
> Rename ContainerManagerImpl to ContainerManagementImpl
> ------------------------------------------------------
>                 Key: YARN-939
>                 URL: https://issues.apache.org/jira/browse/YARN-939
>             Project: Hadoop YARN
>          Issue Type: Task
>          Components: nodemanager
>    Affects Versions: 2.1.0-beta
>            Reporter: Sandy Ryza
>            Assignee: Karthik Kambatla
>              Labels: newbie
> because it now extends ContainerManagementProtocol.  In case this isn't clear, this is
a backwards-compatible change because it's an internal class.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message