hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vinod Kumar Vavilapalli (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-746) rename Service.register() and Service.unregister() to registerServiceListener() & unregisterServiceListener() respectively
Date Thu, 13 Jun 2013 17:41:23 GMT

    [ https://issues.apache.org/jira/browse/YARN-746?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13682459#comment-13682459
] 

Vinod Kumar Vavilapalli commented on YARN-746:
----------------------------------------------

Looks good. +1. Checking this in.
                
> rename Service.register() and Service.unregister() to registerServiceListener() &
unregisterServiceListener() respectively
> --------------------------------------------------------------------------------------------------------------------------
>
>                 Key: YARN-746
>                 URL: https://issues.apache.org/jira/browse/YARN-746
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Steve Loughran
>            Assignee: Steve Loughran
>         Attachments: YARN-746-001.patch
>
>
> make it clear what you are registering on a {{Service}} by naming the methods {{registerServiceListener()}}
& {{unregisterServiceListener()}} respectively.
> This only affects a couple of production classes; {{Service.register()}} and is used
in some of the lifecycle tests of the YARN-530. There are no tests of {{Service.unregister()}},
which is something that could be corrected.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message