hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eli Collins (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-340) Rename DefaultResourceCalculator
Date Fri, 01 Feb 2013 01:46:11 GMT

    [ https://issues.apache.org/jira/browse/YARN-340?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13568365#comment-13568365

Eli Collins commented on YARN-340:

I like MemoryResourceCalculator (or MemoryBasedResourceCalculator) better as well, that was
my first choice, and is what the attached patch uses.  Arun went with that on YARN-2 but people
objected, if people are OK with it now then let's go with it. I don't think proliferation
of many class names will be an issue.
> Rename DefaultResourceCalculator
> --------------------------------
>                 Key: YARN-340
>                 URL: https://issues.apache.org/jira/browse/YARN-340
>             Project: Hadoop YARN
>          Issue Type: Improvement
>    Affects Versions: 2.0.0-alpha
>            Reporter: Eli Collins
>            Assignee: Eli Collins
>            Priority: Minor
>         Attachments: yarn-340.txt, yarn-340.txt
> Let's rename DefaultResourceCalculator to something like MemoryResourceCalculator or
SingleResourceCalculator. The default resource calculator is the one specified by yarn.scheduler.capacity.resource-calculator
in yarn-default.xml (which may change).  We can do this compatibly now since YARN-2 hasn't
been released yet, but changing this later will be a pain if we ever make a different resource
calculator the default (or DefaultResourceCalculator won't actually be the default, which
is weird).

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message