hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vinod Kumar Vavilapalli (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-340) Rename DefaultResourceCalculator
Date Thu, 31 Jan 2013 02:49:13 GMT

    [ https://issues.apache.org/jira/browse/YARN-340?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13567275#comment-13567275
] 

Vinod Kumar Vavilapalli commented on YARN-340:
----------------------------------------------

"Single" is equally confusing ("which one is it?"). How about MemoryBasedResourceCalculator?
Anything more (like MemoryCPUResrouceCalculator), we should religiously invent new names (like
we did for schedulers).
                
> Rename DefaultResourceCalculator
> --------------------------------
>
>                 Key: YARN-340
>                 URL: https://issues.apache.org/jira/browse/YARN-340
>             Project: Hadoop YARN
>          Issue Type: Improvement
>    Affects Versions: 2.0.0-alpha
>            Reporter: Eli Collins
>            Assignee: Eli Collins
>            Priority: Minor
>         Attachments: yarn-340.txt, yarn-340.txt
>
>
> Let's rename DefaultResourceCalculator to something like MemoryResourceCalculator or
SingleResourceCalculator. The default resource calculator is the one specified by yarn.scheduler.capacity.resource-calculator
in yarn-default.xml (which may change).  We can do this compatibly now since YARN-2 hasn't
been released yet, but changing this later will be a pain if we ever make a different resource
calculator the default (or DefaultResourceCalculator won't actually be the default, which
is weird).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message