hadoop-yarn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tao Yang (JIRA)" <j...@apache.org>
Subject [jira] [Created] (YARN-6737) Rename getApplicationAttempt to getCurrentAttempt in AbstractYarnScheduler/CapacityScheduler
Date Fri, 23 Jun 2017 09:23:00 GMT
Tao Yang created YARN-6737:
------------------------------

             Summary: Rename getApplicationAttempt to getCurrentAttempt in AbstractYarnScheduler/CapacityScheduler
                 Key: YARN-6737
                 URL: https://issues.apache.org/jira/browse/YARN-6737
             Project: Hadoop YARN
          Issue Type: Improvement
    Affects Versions: 3.0.0-alpha3, 2.9.0
            Reporter: Tao Yang
            Priority: Minor


As discussed in YARN-6714 (https://issues.apache.org/jira/browse/YARN-6714?focusedCommentId=16052158&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-16052158)
AbstractYarnScheduler#getApplicationAttempt is inconsistent to its name, it discarded application_attempt_id
and always return the latest attempt. We should: 1) Rename it to getCurrentAttempt, 2) Change
parameter from attemptId to applicationId. 3) Took a scan of all usages to see if any similar
issue could happen.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-dev-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-dev-help@hadoop.apache.org


Mime
View raw message