hadoop-yarn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karthik Kambatla <ka...@cloudera.com>
Subject [DISCUSS] Deprecating and removing DockerContainerExecutor
Date Thu, 06 Oct 2016 13:25:27 GMT
Hi folks

I am emailing here to bring attention to YARN-5388 that proposes to
deprecate DockerContainerExecutor (DCE) in 2.x and its removal in 3.0.

DCE was released in 2.6. Since then, the LinuxContainerExecutor has been
augmented to support Docker containers alongside non-Docker ones. Given the
duplication and maturity of the latter, the proposal is to deprecate DCE in
2.x and remove it in 3.0.

Thoughts?

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message