hadoop-yarn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arun Suresh (JIRA)" <j...@apache.org>
Subject [jira] [Created] (YARN-5457) Refactor DistributedScheduling framework to pull out common functionality
Date Sun, 31 Jul 2016 19:14:20 GMT
Arun Suresh created YARN-5457:
---------------------------------

             Summary: Refactor DistributedScheduling framework to pull out common functionality
                 Key: YARN-5457
                 URL: https://issues.apache.org/jira/browse/YARN-5457
             Project: Hadoop YARN
          Issue Type: Sub-task
            Reporter: Arun Suresh


Opening this JIRA to track the following refactoring missed in YARN-5113:

* Move {{OpportunisticContainerAllocator}} to yarn-server-common
** Fix the constructor to just pass in the appropriate TokenSecretManager instead of the NodeStatusUpdater.
* Move the {{DistributedScheduler}} class to yarn-server-common and probably move all the
app specific bookkeeping to the SchedulerNode.
* Rename {{DistributedSchedulingAMService}} to {{OpportunisticSchedulingAMService}}
** modify the {{getServer}} method to enable the new protocol only if DistributedScheduling
is enabled.
** modify the allocate method to intercept all OPPORTUNISTIC requests and use the {{OpportunisticContainerAllocator}}
to allocate and create the containers.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-dev-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-dev-help@hadoop.apache.org


Mime
View raw message