hadoop-yarn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vinod Kumar Vavilapalli <vino...@apache.org>
Subject Re: Setting JIRA fix versions for 3.0.0 releases
Date Fri, 22 Jul 2016 23:53:10 GMT
I’ve been using jdiff simply because of a lack of alternative.

If you’ve had experience with tool [1], if you think it serves our purpose, and if you can
spare some time, that’ll be greatly appreciated. I can also pitch in with whatever help
is needed.

I think we should pick one of 2.6.3 or 2.7.2 as baseline.

Thanks
+Vinod

> On Jul 21, 2016, at 2:41 PM, Sean Busbey <busbey@cloudera.com> wrote:
> 
> I can come up with this, atleast for Source / Binary API compatibility,
> provided folks don't mind if I use the Java API Compliance Checker[1]
> instead of jdiff.
> 
> I'm already familiar with quickly using it, esp with Audience
> Annotations from my work in HBase.
> 
> Do you want this check from some particular branch-2 release? It
> matters since the releases along branch-2 have themselves had some
> noise[2].
> 
> [1]: https://github.com/lvc/japi-compliance-checker <https://github.com/lvc/japi-compliance-checker>
> [2]: http://abi-laboratory.pro/java/tracker/timeline/hadoop/ <http://abi-laboratory.pro/java/tracker/timeline/hadoop/>
> 
> -- 
> busbey


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message