hadoop-yarn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tsuyoshi Ozawa <oz...@apache.org>
Subject Re: [DICUSS] Upgrading Guice to 4.0(HADOOP-12064)
Date Wed, 29 Jun 2016 19:27:05 GMT
I forgot to mention about importance point: it's a blocker issue to
compile Hadoop with JDK8. Hence, we need to merge it on both client
side and server slide anyway.

Thanks,
- Tsuyoshi

On Wed, Jun 29, 2016 at 12:24 PM, Tsuyoshi Ozawa <ozawa@apache.org> wrote:
> Thanks Vinod, Sangjin, Sean for your comment.
>
> Okay, I will take a look at the class path isolation.
> Should I postpone to merge Guice upgrade to trunk? IMHO, it works with
> tests, so it's okay to merge to runk. Thoughts?
>
> - Tsuyoshi
>
> On Wed, Jun 29, 2016 at 12:10 PM, Sangjin Lee <sjlee@apache.org> wrote:
>> Yeah it would be awesome if we can get feedback and/or suggestions on these
>> JIRAs (HADOOP-11804 and HADOOP-13070).
>>
>> Thanks,
>> Sangjin
>>
>> On Wed, Jun 29, 2016 at 10:55 AM, Sean Busbey <busbey@cloudera.com> wrote:
>>>
>>> At the very least, I'm running through an updated shaded hadoop client
>>> this week[1] (HBase is my test application and it wandered onto some
>>> private things that broke in branch-2). And Sangjin has a good lead on
>>> an lower-short-term-cost incremental improvement for runtime isolation
>>> of apps built on yarn/mapreduce[2]. He's been patiently waiting for
>>> more review feedback.
>>>
>>>
>>> [1]: https://issues.apache.org/jira/browse/HADOOP-11804
>>> [2]: https://issues.apache.org/jira/browse/HADOOP-13070
>>>
>>> On Wed, Jun 29, 2016 at 12:33 PM, Vinod Kumar Vavilapalli
>>> <vinodkv@apache.org> wrote:
>>> > My strong expectation is that we’ll have a version of classpath
>>> > isolation in our first release of 3.x. I’m planning to spending some cycles
>>> > right away on this.
>>> >
>>> > Assuming classpath isolation gets in, it is reasonable to bump up our
>>> > dependencies like Jetty / Guice to the latest stable versions.
>>> >
>>> > Thanks
>>> > +Vinod
>>> >
>>> >> On Jun 27, 2016, at 6:01 AM, Tsuyoshi Ozawa <ozawa@apache.org>
wrote:
>>> >>
>>> >> Hi developers,
>>> >>
>>> >> I will plan to upgrade Google Guice dependency on trunk. The change
>>> >> also includes asm and cglib upgrade.
>>> >> I checked following points:
>>> >>
>>> >> * Both HDFS and YARN UIs work well.
>>> >> * All webIU-related tests pass as described on HADOOP-12064.
>>> >> * Ran mapreduce job, and it works well.
>>> >>
>>> >> https://issues.apache.org/jira/browse/HADOOP-12064
>>> >>
>>> >> Do you have any concern or opinion?  I would like to merge it to trunk
>>> >> on this Friday if you have no objections.
>>> >>
>>> >> Best,
>>> >> - Tsuyoshi
>>> >>
>>> >> ---------------------------------------------------------------------
>>> >> To unsubscribe, e-mail: common-dev-unsubscribe@hadoop.apache.org
>>> >> For additional commands, e-mail: common-dev-help@hadoop.apache.org
>>> >>
>>> >>
>>> >
>>> >
>>> > ---------------------------------------------------------------------
>>> > To unsubscribe, e-mail: mapreduce-dev-unsubscribe@hadoop.apache.org
>>> > For additional commands, e-mail: mapreduce-dev-help@hadoop.apache.org
>>> >
>>>
>>>
>>>
>>> --
>>> busbey
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: common-dev-unsubscribe@hadoop.apache.org
>>> For additional commands, e-mail: common-dev-help@hadoop.apache.org
>>>
>>

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-dev-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-dev-help@hadoop.apache.org


Mime
View raw message