hadoop-yarn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Allen Wittenauer ...@apache.org>
Subject Re: [DISCUSS] Set minimum version of Hadoop 3 to JDK8 (HADOOP-11858)
Date Tue, 10 May 2016 16:09:47 GMT

> On May 10, 2016, at 8:32 AM, Akira AJISAKA <ajisakaa@oss.nttdata.co.jp> wrote:
> 
> Hi developers,
> 
> Before cutting 3.0.0-alpha RC, I'd like to drop JDK7 support in trunk.

	+1 yes please.  

> One concern I think is, when the minimum version is set to JDK8, we need to configure
Jenkins to disable multi JDK test only in trunk.

Two points:

	* The feature to do this in test-patch is already on the roadmap, since HBase asked already:
YETUS-369 .  We’re really close to releasing Apache Yetus 0.3.0, so it won’t show up until
0.4.0 though.  It’s a non-trivial change on it’s own, and based on some conversations
I’ve been having this week with other Yetus users, I’m thinking we may want to rewrite
how multijdkmode works anyway.

	* It’s feasible to just disable multijdkmode in precommit and then rely upon the regularly
scheduled builds to tell us if branch-2 gets broken by a JDK8-only patch.  (FWIW: I’ll be
talking about it during ApacheCon, but I’ve been working on a Yetus-ified replacement for
those “build the world” jobs such that they are actually useful, less frequent, easier
to read, less likely to break due to running in a docker container, etc, etc.)
---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-dev-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-dev-help@hadoop.apache.org


Mime
View raw message