hadoop-yarn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zhijie Shen (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (YARN-2239) Rename ClusterMetrics#getUnhealthyNMs() to getNumUnhealthyNMs()
Date Fri, 01 May 2015 20:43:08 GMT

     [ https://issues.apache.org/jira/browse/YARN-2239?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Zhijie Shen resolved YARN-2239.
-------------------------------
    Resolution: Invalid

Change in ClusterMetricsInfo is incompatible. The name has been used since 2.4. Let's keep
to it. Feel free to reopen it if you have different thoughts.

> Rename ClusterMetrics#getUnhealthyNMs() to getNumUnhealthyNMs()
> ---------------------------------------------------------------
>
>                 Key: YARN-2239
>                 URL: https://issues.apache.org/jira/browse/YARN-2239
>             Project: Hadoop YARN
>          Issue Type: Improvement
>          Components: resourcemanager
>    Affects Versions: 2.4.0
>            Reporter: Kenji Kikushima
>            Assignee: Kenji Kikushima
>            Priority: Trivial
>         Attachments: YARN-2239.patch
>
>
> In ClusterMetrics, other get NMs() methods have "Num" prefix. (Ex. getNumLostNMs()/getNumRebootedNMs())
> For naming consistency, we should rename getUnhealthyNMs() to getNumUnhealthyNMs().



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message