hadoop-yarn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eli Collins <...@cloudera.com>
Subject Re: When to mark a JIRA incompatible?
Date Wed, 08 Jan 2014 01:05:31 GMT
When it's incompatible with a previous release. You can change a new public
API several times in an incompatible way before you release it. Not yarn
specific btw, same rules for all of Hadoop.

On Tuesday, January 7, 2014, Karthik Kambatla wrote:

> Hey devs,
>
> Was just wondering if the Incompatible Change flag on JIRA is to be checked
> if the patch is incompatible with an existing release or even if it is
> incompatible with contents of branch-2?
>
> For instance, YARN-1568 fixes something introduced by YARN-1029 that was
> only committed yesterday, but in an incompatible way.
>
> Thanks
> Karthik
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message