hadoop-yarn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Harsh J <ha...@cloudera.com>
Subject Re: Build error
Date Fri, 22 Mar 2013 18:21:48 GMT
I built trunk today on OSX Lion with

➜  src git:(trunk) ✗ java -version
java version "1.6.0_41"
Java(TM) SE Runtime Environment (build 1.6.0_41-b02-445-11M4107)
Java HotSpot(TM) 64-Bit Server VM (build 20.14-b01-445, mixed mode)

And it built alright.

So yes, I'm guessing this is a bug with the build framework (Groovy?)
not accepting JDK7 well. I think this may be the same as
https://issues.apache.org/jira/browse/HADOOP-9350. Try following the
workaround mentioned there?

On Fri, Mar 22, 2013 at 1:35 PM, Timothy Chen <tnachen@gmail.com> wrote:
> Hi all,
>
> I got this error trying to mvn build from trunk top folder with Mac,
>
> java version "1.7.0_10"
> Java(TM) SE Runtime Environment (build 1.7.0_10-b18)
> Java HotSpot(TM) 64-Bit Server VM (build 23.6-b04, mixed mode)
>
> error:
>
> Exception in thread "main" java.lang.AssertionError: Missing tools.jar at:
> /Library/Java/JavaVirtualMachines/jdk1.7.0_10.jdk/Contents/Home/Classes/classes.jar.
> Expression: file.exists()
> at
> org.codehaus.groovy.runtime.InvokerHelper.assertFailed(InvokerHelper.java:395)
>
> Anyone encountered this before? Or I should be using jdk 1.6?
>
> Tim



-- 
Harsh J

Mime
View raw message