hadoop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From karthi keyan <karthi93.san...@gmail.com>
Subject Re: Re: UnstaisfiedLinkError - Windows Environment
Date Tue, 29 Mar 2016 09:31:08 GMT
I too thought version will be the problem but, Same Package works fine for
another Server (remote Cluster with same Hadoop 2.5.2) . See here i have to
clarify my use case,

1. Having a Small sample(*client*) which is built with Hadoop *2.6.2 (*Built
with .net framework 4.0 and JDK 1.8 in 64 bit env)

2. Having a Remote cluster (*server*) which is built with Hadoop *2.5.2 *
* (*Built with .net framework 4.0 and JDK 1.7 in 64 bit env )

3. When i intend to access the Data from *Server*(Remote cluster with
Hadoop 2.5.2 ) with my *client *Api , Above exception will rise.

@*hsdcloud@163.com <hsdcloud@163.com> *As you said the version will be
same, But it works fine When If *server* is running in another machine with
same environment.

As now i have the changed to another Server(remote Cluster) and working
fine !!
Am little bit confused with the exception where it occurs either problem
with Version/DLL or with System Environment??




On Tue, Mar 29, 2016 at 2:33 PM, hsdcloud@163.com <hsdcloud@163.com> wrote:

> i think the root cause is version ,  suggest your built jar use
> hadoop2.5.2 ,the same version
>
> ------------------------------
> hsdcloud@163.com
>
>
> *From:* karthi keyan <karthi93.sankar@gmail.com>
> *Date:* 2016-03-29 17:16
> *To:* Brahma Reddy Battula <brahmareddy.battula@huawei.com>
> *CC:* user@hadoop.apache.org
> *Subject:* Re: UnstaisfiedLinkError - Windows Environment
> Only side libraries are built with Hadoop 2.6.2 , But Server(Remote
> Cluster) is built with Hadoop 2.5.2? Am not sure that version not be the
> case here.. Don't know wy it happens ? does you knw the cause of this
> exception ?
>
>

Mime
View raw message