hadoop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anand Murali <anand_vi...@yahoo.com>
Subject Re: Connection Refused Error
Date Mon, 20 Apr 2015 13:26:13 GMT
Himanwan:
Jps fails on my laptop although JDK1.7.0 is installed. There is no etc/hosts and the slaves
file has one entry called localhost
 Anand Murali  11/7, 'Anand Vihar', Kandasamy St, MylaporeChennai - 600 004, IndiaPh: (044)-
28474593/ 43526162 (voicemail) 


     On Monday, April 20, 2015 6:47 PM, Himawan Mahardianto <mahardianto@ugm.ac.id>
wrote:
   

 Are you sure the namenode is running well from ouput on jps command?Have you try to give
an IP on your PC other than 127.0.0.1?and could you paste your /etc/hosts and hadoop_folder/etc/hadoop/slaves
file configuration on this reply?
On Mon, Apr 20, 2015 at 8:10 PM, Anand Murali <anand_vihar@yahoo.com> wrote:

Hi
But the Hadoop wiki say this is a network issue especially with Ubuntu. Please look at my
paste and follow thru link.
As regards my temporary solution. I have to remove all Hadoop files and re extract it and
start over and then it works for a couple of runs before it starts all over again.

Sent from my iPhone
On 20-Apr-2015, at 6:21 pm, Himawan Mahardianto <mahardianto@ugm.ac.id> wrote:


you just run "jps" on your terminal, here my jps output command on my namenode:hadoop@node-17:~$
jps18487 Jps18150 NameNode18385 SecondaryNameNodehadoop@node-17:~$ from that output I could
make sure that my namenode is running well, how bout your namenode, are you sure it's running
well or not?
On Mon, Apr 20, 2015 at 7:24 PM, Anand Murali <anand_vihar@yahoo.com> wrote:

No. I shall try. Can you point me to jps resources.
Thanks
 Anand Murali  11/7, 'Anand Vihar', Kandasamy St, MylaporeChennai - 600 004, IndiaPh: (044)-
28474593/ 43526162 (voicemail) 


     On Monday, April 20, 2015 5:50 PM, Himawan Mahardianto <mahardianto@ugm.ac.id>
wrote:
   

 have you try jps command and looking what hadoop service is running?  
On Mon, Apr 20, 2015 at 6:45 PM, Anand Murali <anand_vihar@yahoo.com> wrote:

Yes. All Hadoop commands. The error message is linked to IP address,a dn I checked Hadoop
wiki, this is a network issue on Ubuntu. Unfortunately, I dont know much about networks.
 Anand Murali  11/7, 'Anand Vihar', Kandasamy St, MylaporeChennai - 600 004, IndiaPh: (044)-
28474593/ 43526162 (voicemail) 


     On Monday, April 20, 2015 5:13 PM, Himawan Mahardianto <mahardianto@ugm.ac.id>
wrote:
   

 have you try: hdfs dfs -ls / *with slash in the end of command?
On Mon, Apr 20, 2015 at 5:50 PM, Anand Murali <anand_vihar@yahoo.com> wrote:

Hi All:
I am using Ubuntu 14.10 desktop and Hadoop-2.6 pseudo mode. Start-dfs/Stop-dfs is normal.
However, after a couple of times of usage, when I try to connect to HDFS,, I am refused connection.
Find below
anand_vihar@Latitude-E5540:~$ ssh localhost
Welcome to Ubuntu 14.10 (GNU/Linux 3.16.0-34-generic x86_64)

 * Documentation:  https://help.ubuntu.com/

Last login: Mon Apr 20 15:43:58 2015 from localhost
anand_vihar@Latitude-E5540:~$ cd hadoop-2.6.0
anand_vihar@Latitude-E5540:~/hadoop-2.6.0$ . .hadoop
/home/anand_vihar/hadoop-2.6.0
/home/anand_vihar/jdk1.7.0_75
/home/anand_vihar/hadoop-2.6.0
anand_vihar@Latitude-E5540:~/hadoop-2.6.0$ start-dfs.sh
Starting namenodes on [localhost]
localhost: starting namenode, logging to /home/anand_vihar/hadoop-2.6.0/logs/hadoop-anand_vihar-namenode-Latitude-E5540.out
localhost: starting datanode, logging to /home/anand_vihar/hadoop-2.6.0/logs/hadoop-anand_vihar-datanode-Latitude-E5540.out
Starting secondary namenodes [0.0.0.0]
0.0.0.0: starting secondarynamenode, logging to /home/anand_vihar/hadoop-2.6.0/logs/hadoop-anand_vihar-secondarynamenode-Latitude-E5540.out
anand_vihar@Latitude-E5540:~/hadoop-2.6.0$ hdfs dfs -ls
ls: Call From Latitude-E5540/127.0.1.1 to localhost:9000 failed on connection exception: java.net.ConnectException:
Connection refused; For more details see:  http://wiki.apache.org/hadoop/ConnectionRefused
anand_vihar@Latitude-E5540:~/hadoop-2.6.0$ 



If I completely delete Hadoop and re-install, it starts working. Can somebody advise on this
issue.
Many thanks

Regards
 Anand Murali  




   



   






  
Mime
View raw message