hadoop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Lee <eliy...@hotmail.com>
Subject RE: Wordcount file cannot be located
Date Fri, 02 May 2014 04:08:12 GMT
I tried to add the code, but seems still not working.
2014-05-02 11:56:06,780 WARN  [main] util.NativeCodeLoader (NativeCodeLoader.java:<clinit>(62))
- Unable to load native-hadoop library for your platform... using builtin-java classes where
java.io.IOException: No FileSystem for scheme: hdfs
Also, the eclipse DFS location can reach the /tmp/ but cannot enter the /user/
Any suggestion, thanks.
From: unmeshabiju@gmail.com
Date: Fri, 2 May 2014 08:43:26 +0530
Subject: Re: Wordcount file cannot be located
To: user@hadoop.apache.org

Try this along with your MapReduce source code

Configuration config = new Configuration();config.set("fs.defaultFS", "hdfs://IP:port/");

FileSystem dfs = FileSystem.get(config);Path path = new Path("/tmp/in");

Let me know your thoughts.

Thanks & Regards

Unmesha Sreeveni U.B
Hadoop, Bigdata Developer

Center for Cyber Security | Amrita Vishwa Vidyapeetham

View raw message