hadoop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From SF Hadoop <sfhad...@gmail.com>
Subject Not information in Job History UI
Date Mon, 03 Mar 2014 18:45:50 GMT
Hadoop 2.2.0
CentOS 6.4
Viewing UI in various browsers.

I am having a problem where no information is visible in my Job History UI.
 I run test jobs, they complete without error, but no information ever
populates the nodemanager or jobhistory server UI.

Also, there are no job logs generated on the server that is running the job.

I have the following settings configured:
yarn.nodemanager.local-dirs
yarn.nodemanager.log-dirs
yarn.log.server.url

...plus the basic yarn log dir.  I get output in regards to the daemons but
very little in regards to the job.  All I get that refers to the jobhistory
server is the following (so it appears to be functioning properly):

2014-02-18 11:43:06,824 INFO org.apache.hadoop.http.HttpServer: Jetty bound
to port 19888
2014-02-18 11:43:06,824 INFO org.mortbay.log: jetty-6.1.26
2014-02-18 11:43:06,847 INFO org.mortbay.log: Extract
jar:file:/usr/lib/hadoop-yarn/hadoop-yarn-common-2.1.0.2.0.5.0-67.jar!/webapps/jobhistory
to /tmp/Jetty_server_19888_jobhistory____v7gnnv/webapp
2014-02-18 11:43:07,085 INFO org.mortbay.log: Started
SelectChannelConnector@server:19888
2014-02-18 11:43:07,085 INFO org.apache.hadoop.yarn.webapp.WebApps: Web app
/jobhistory started at 19888
2014-02-18 11:43:07,477 INFO org.apache.hadoop.yarn.webapp.WebApps:
Registered webapp guice modules

I have a feeling this is a misconfiguration but I cannot figure out what
setting is missing or wrong.

Other than not being able to see any of the jobs in the UIs, everything
appears to be working correctly so this is quite confusing.

Any help is appreciated.

Mime
View raw message