hadoop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Viral Bajaria <viral.baja...@gmail.com>
Subject KerberosUtil in hadoop 0.23
Date Mon, 04 Feb 2013 06:26:39 GMT
Hi,

I was trying to build hbase 0.94 against hadoop 0.23 but kept on getting
compilation errors. It complained about the KerberosUtil class which it
required but for some reason that class is missing in 0.23.4 but exists in
other branches i.e. 0.22 and on 2.0

Is this because 0.23 is not an actively maintained branch or is it due to
some other reasons ? Should I just port the class over to my repo and build
hadoop again ? I already did it and replaced the hadoop-auth release in my
local repository to allow hbase to compile and it worked fine. Though I am
not sure about any side effects unless and until I run real traffic against
this.

Wanted to run this by the community to see if anyone has run hbase 0.92
against hadoop 0.23.x and if yes did you have to back port the said
KerberosUtil class ?

Thanks,
Viral

Mime
View raw message