hadoop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Harsh J <ha...@cloudera.com>
Subject Re: Failed to start Apache pig on Hadoop
Date Fri, 07 Dec 2012 04:48:05 GMT
0. I don't think this message is critical. It is just a warning, not an
error.
1. It is cause of the configuration of the default log4j.properties shipped
in either Pig or your Hadoop
2. You seem to be using a very old version of Apache Hadoop if its pure
0.20.1. Please try upgrading to one of the most recent releases.
3. To make the warning go away, try to find and fix the log4j.properties
file line that carries the EventCounter, to the one it recommends you to
use.


On Fri, Dec 7, 2012 at 8:27 AM, Dora <dora0009@gmail.com> wrote:

> Hello everyone,
>
> I'm Dora, a beginner of Hadoop.
>
> Anyway, did anyone encounter the following issue?
> WARNING: org.apache.hadoop.metrics.jvm.EventCounter is deprecated.
> Please use org.apache.hadoop.log.metrics.EventCounter in all the
> log4j.properties files.
>
> After I install the Apache pig and try the "pig" command on Linux, the
> above warning was turn up.
> Does anyone knows why it happened?
>
> P.S
> Apache Pig version : 0.10.0
> Hadoop Version : 0.20.1
>
>
> Best Regards,
> Dora
>



-- 
Harsh J

Mime
View raw message