hadoop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dhaval Shah <prince_mithi...@yahoo.co.in>
Subject Re: HDFS Web UI - Incorrect context
Date Mon, 26 Nov 2012 21:44:24 GMT
Alright.. The issue was with packaging.. If you have the pig jar in the classpath, it messes
up
 
Regards,
Dhaval


________________________________
 From: Harsh J <harsh@cloudera.com>
To: "<user@hadoop.apache.org>" <user@hadoop.apache.org>; Dhaval Shah <prince_mithibai@yahoo.co.in>

Sent: Saturday, 24 November 2012 2:30 AM
Subject: Re: HDFS Web UI - Incorrect context
 
Few questions:

1. What do you mean by a "Tomcat context"? The HDFS core daemons (NN,
DN, SNN, etc.) use Jetty to deploy their HTTP servlets, not Tomcat.
2. Did you run a build on your install and are using a built classpath
instead of the installed one?

In any case, if your problem is specific to CDH packages, please send
your mail with more details on your packages/setup instead to
cdh-user@cloudera.org
(https://groups.google.com/a/cloudera.org/forum/?fromgroups=#!forum/cdh-user).

On Sat, Nov 24, 2012 at 1:57 AM, Dhaval Shah
<prince_mithibai@yahoo.co.in> wrote:
> Hello everyone.. I have a very weird issue at hand.. I am using CDH4.0.0 on
> one of my clusters and it works perfectly fine.. Now I tried deploying the
> same packages to another cluster with very similar configs (the only
> difference is machine names).. Hadoop does come up but the HDFS UI seems to
> have an incorrect Tomcat context.. The only thing it shows up is
>
> Directory: /
> webapps/ 4096 bytes Nov 23, 2012 2:44:13 PM
>
> When I click on webapps, it shows an option for hdfs and when I click hdfs,
> it takes me to http://localhost:50070/webapps/hdfs/dfshealth.jsp which
> throws a 404.. Ideally /webapps/hdfs should have been the root context and
> this works correctly on my other cluster.. Any pointers?
>
> Regards,
> Dhaval



-- 
Harsh J
Mime
View raw message