hadoop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jaco Joubert <jdjoub...@gmail.com>
Subject Re: HDFS BackupNode support in 1.0.3
Date Fri, 26 Oct 2012 19:31:03 GMT
Thanks a lot for clearing this up.

On Thu, Oct 25, 2012 at 4:55 PM, Harsh J <harsh@cloudera.com> wrote:

> Jaco,
>
> There is no BackupNode in 1.x. The docs were by mistake, see
> http://search-hadoop.com/m/RMLq71stu6W.
>
> Also, we're removing BackupNode and CheckpointNode in future (trunk
> for now) in favor of HA NameNodes and the SecondaryNameNode.
>
> On Thu, Oct 25, 2012 at 8:13 PM, Jaco Joubert <jdjoubert@gmail.com> wrote:
> > Hi,
> >
> > I installed version 1.0.3 of Hadoop and I'm interested in running the
> > BackupNode.
> > The user guide explains the BackupNode and how to configure / start it:
> > http://hadoop.apache.org/docs/r1.0.3/hdfs_user_guide.html#Backup+Node
> > I'm having difficulty starting the BackupNode and I assume that either
> the
> > documentation is out-of-synch, or the BackupNode is not really supported
> in
> > 1.0.3.  I say this because:
> >
> > The documented command to start the BackupNode doesn't exist:
> > bin/hdfs namenode -checkpoint
> > (the "hdfs" script doesn't exist at all)
> >
> > I also tried the "bin/hadoop namenode" command, but it only supports
> these
> > arguments:
> > Usage: java NameNode [-format] | [-upgrade] | [-rollback] | [-finalize] |
> > [-importCheckpoint]
> >
> > Am I doing something wrong, or is the BackupNode not supported in 1.0.3
> (and
> > therefore the documentation incorrect)?
> >
> > Regards,
> > Jaco
>
>
>
> --
> Harsh J
>

Mime
View raw message