hadoop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xia, Junluan" <junluan....@intel.com>
Subject issues when running distributedShell example in hadoop-2.0.1-alpha
Date Mon, 29 Oct 2012 11:32:42 GMT

         I have successfully run distributed Shell example in single node that deployed the
         But when I run distributedShell in cluster environment, sometimes it works well,
but sometimes it will failed, following is my detail configuration

A: NameNode, ResourceManager
         B: DataNode, NodeManager
         C: DataNode, NodeManager

         I run the distributedShell with command
"./bin/hadoop jar share/hadoop/mapreduce/hadoop-yarn-applications-distributedshell-2.0.1-alpha.jar
org.apache.hadoop.yarn.applications.distributedshell.Client -jar share/hadoop/mapreduce/hadoop-yarn-applications-distributedshell-2.0.1-alpha.jar
-shell_command whoami  -debug"
When application master is launched, it will create the container to run shell command "whoami",
so application master will run on node B or C, and container will also randomly run on B or
C, if application master and shell command container run on the same node(for example all
on node B), above command will run successfully, but if in different node, that is to say,
if application master launched successfully in node B and it create the container that will
run on node C, I will receive the error message

12/10/29 19:18:02 INFO distributedshell.Client: Application did finished unsuccessfully. YarnState=FINISHED,
DSFinalStatus=FAILED. Breaking monitoring loop
12/10/29 19:18:02 ERROR distributedshell.Client: Application failed to complete successfully"

Have anyone encounter similar issue?


View raw message