hadoop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alan Miller <Alan.Mil...@synopsys.com>
Subject RE: datanode startup before hostname is resovable
Date Wed, 08 Aug 2012 07:43:24 GMT
Sure but like I said, I’m on DHCP so my IP always changes.

In my config files I tried using “localhost4” and “” but in
both cases it still uses my FQ hostname instead of
  STARTUP_MSG:   host = myhostname.mycompany.com/
  STARTUP_MSG:   args = []
  STARTUP_MSG:   version = 2.0.0-cdh4.0.1

From: /etc/hadoop/conf/core-site.xml

From: /etc/hadoop/conf/mapred-site.xml

From: Chandra Mohan, Ananda Vel Murugan [mailto:Ananda.Murugan@honeywell.com]
Sent: Wednesday, August 08, 2012 9:19 AM
To: user@hadoop.apache.org
Subject: RE: datanode startup before hostname is resovable

I had a similar problem under different circumstances. I added the hostname and ip in /etc/hosts

From: Alan Miller [mailto:Alan.Miller@synopsys.com]<mailto:[mailto:Alan.Miller@synopsys.com]>
Sent: Wednesday, August 08, 2012 12:32 PM
To: user@hadoop.apache.org<mailto:user@hadoop.apache.org>
Subject: datanode startup before hostname is resovable

For development I run CDH4 on my local machine  but I notice that I have to
manually start the datanode (sudo service hadoop-hdfs-datanode start)
after each reboot.

Looks like the datanode process is getting started before my DHCP address Is resolvable.
From:  /var/log/hadoop-hdfs/hadoop-hdfs-datanode-myhost.log

    2012-08-08 08:44:01,171 INFO org.apache.hadoop.hdfs.server.datanode.DataNode: STARTUP_MSG:
    STARTUP_MSG: Starting DataNode
    STARTUP_MSG:   host = java.net.UnknownHostException: myhostname: myhostname
    2012-08-08 08:44:02,253 ERROR org.apache.hadoop.hdfs.server.datanode.DataNode: Exception
in secureMain java.net.UnknownHostException: myhostname: myhostname
    SHUTDOWN_MSG: Shutting down DataNode at java.net.UnknownHostException: myhostname: myhostname

I’m on Fedora 16/x86_64.


View raw message