hadoop-pig-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xuefu Zhang (JIRA)" <j...@apache.org>
Subject [jira] Commented: (PIG-1292) Interface Refinements
Date Thu, 11 Mar 2010 23:54:27 GMT

    [ https://issues.apache.org/jira/browse/PIG-1292?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12844282#action_12844282
] 

Xuefu Zhang commented on PIG-1292:
----------------------------------

A few comments from my personal perspective:

1. WritableComparable<?> getSplitComparable(PigSplit split) should not pass PigSplit
instace. Instead, it should only pass the actual split wrapped in PigSplit. On interface level,
the type should be just InputSplit.

2. In CollectableLoadFunc interface, void should be the return type. If a LoadFunc implementation
implements the interface, it means it's capable to support what is asking for. There is no
point to implement an interface and later to say it's not capably to do what the interface
is asking.

3. ensureAllKeyInstancesInSameSplit() method might need a better name. However, comparing
to another two issues, this is minor.

> Interface Refinements
> ---------------------
>
>                 Key: PIG-1292
>                 URL: https://issues.apache.org/jira/browse/PIG-1292
>             Project: Pig
>          Issue Type: Bug
>    Affects Versions: 0.7.0
>            Reporter: Ashutosh Chauhan
>            Assignee: Ashutosh Chauhan
>             Fix For: 0.7.0
>
>         Attachments: pig-interfaces.patch
>
>
> A loader can't implement both OrderedLoadFunc and IndexableLoadFunc, as both are abstract
classes instead of being interfaces.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message