hadoop-mapreduce-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rammohan ganapavarapu <rammohanga...@gmail.com>
Subject Re: ACCEPTED: waiting for AM container to be allocated, launched and register with RM
Date Fri, 19 Aug 2016 03:14:04 GMT
Sunil,

Thanks you for your input, below are my server metrics for RM. Also
attached RM UI for capacity scheduler resources. How else i can find?

{
      "name": "Hadoop:service=ResourceManager,name=QueueMetrics,q0=root",
      "modelerType": "QueueMetrics,q0=root",
      "tag.Queue": "root",
      "tag.Context": "yarn",
      "tag.Hostname": "hadoop001",
      "running_0": 0,
      "running_60": 0,
      "running_300": 0,
      "running_1440": 0,
      "AppsSubmitted": 1,
      "AppsRunning": 0,
      "AppsPending": 0,
      "AppsCompleted": 0,
      "AppsKilled": 0,
      "AppsFailed": 1,
      "AllocatedMB": 0,
      "AllocatedVCores": 0,
      "AllocatedContainers": 0,
      "AggregateContainersAllocated": 2,
      "AggregateContainersReleased": 2,
      "AvailableMB": 64512,
      "AvailableVCores": 24,
      "PendingMB": 0,
      "PendingVCores": 0,
      "PendingContainers": 0,
      "ReservedMB": 0,
      "ReservedVCores": 0,
      "ReservedContainers": 0,
      "ActiveUsers": 0,
      "ActiveApplications": 0
    },

On Thu, Aug 18, 2016 at 6:49 PM, Sunil Govind <sunil.govind@gmail.com>
wrote:

> Hi
>
> It could be because of many of reasons. Also I am not sure about which
> scheduler your are using, pls share more details such as RM log etc.
>
> I could point out few reasons
>  - Such as "Not enough resource is cluster" can cause this
>  - If using Capacity Scheduler, if queue capacity is maxed out, such case
> can happen.
>  - Similarly if max-am-resource-percent is crossed per queue level, then
> also AM container may not be launched.
>
> you could check RM log to get more information if AM container is laucnhed.
>
> Thanks
> Sunil
>
> On Fri, Aug 19, 2016 at 5:37 AM rammohan ganapavarapu <
> rammohanganap@gmail.com> wrote:
>
>> Hi,
>>
>> When i submit a MR job, i am getting this from AM UI but it never get
>> finished, what am i missing ?
>>
>> Thanks,
>> Ram
>>
>

Mime
View raw message