hadoop-mapreduce-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vineet Mishra <clearmido...@gmail.com>
Subject Hive Server Load Data InPath Fails
Date Fri, 11 Sep 2015 07:09:47 GMT
Hi All,

I am making a Hive Thrift connection to Hive Server and with load data
inpath command to one of my table I am landing into some bizzare exception.

Other queries seems out to be working fine, but this is the only query
which is getting failed

15/09/11 11:40:32 ERROR utils.HCatalogUtil: Executing Query: load data
inpath '/data/mount/si/piu/' overwrite into table scnrt2.piu
HiveServerException(message:Query returned non-zero code: 10001, cause:
FAILED: SemanticException [Error 10001]: Line 1:130 Table not found 'piu',
errorCode:10001, SQLState:42S02)

The table is created in the scnrt2 database and exist before the command is

I have even tried executing the same query using the query "use scnrt2"
before firing the load data but still not luck, while the same query is
executing fine from the hive command line.

Any quick feedback would be appreciated!


View raw message