hadoop-mapreduce-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sajid mohammed <sajid.had...@gmail.com>
Subject Re: "ssh localhost" returns "connection closed by ::1" under Cygwin installation on windows 8
Date Fri, 24 Jul 2015 05:25:27 GMT
This May help you

I experienced this same issue. The problem for me at least, was the
creation of the cyg_server user using the ssh-host-config. It was created
without a home directory and with it's shell set to /bin/false. So, I
altered the /etc/passwd file for the cyg_server user to reflect
/home/cyg_server (changed from /var/empty) and /bin/false to /bin/bash and
created the home directory for the user. Tried to reconnect using the
cyg_server user and voila.

in short: mkdir /home/cyg_server vim /etc/passwd cyg_server:...(bunch of
stuff)...:/var/empty:/bin/false to cyg_server:...(bunch of

Presumably cygwin has a usermod command or synonym that would do this a
little safer. But I was impatient and this is what I did. If anyone follows
this please note to be extremely careful when editing the /etc/passwd file.

On Fri, Jul 24, 2015 at 3:05 AM, Yepeng Sun <yepeng.sun@llamasoft.com>

>  Hi,
> I tried to install Hadoop on windows 8 to form multi-node clusters. So
> first I have to install Cygwin in order to make SSH working. I installed
> Cygwin with Sshd service successfully. And also I generated passwordless
> keys. But when I run “ssh localhost”, it returns “connection closed by
> ::1”. Does anyone has the same experience? How did you solve it.
> Thanks!
> Yepeng

View raw message