hadoop-mapreduce-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jagat Singh <jagatsi...@gmail.com>
Subject Single node Hortonworks 2.3 VM and Hue 3.8.1 Oozie job submission stuck in Prep state
Date Sun, 26 Jul 2015 11:23:50 GMT
Hi,

I am using single node virtual machine from Hortonworks 2.3

I have configured Hue on the same machine and whenever i submit any job via
oozie all go to pending state.

I can see the shared library present in the folder

[hue@sandbox oozie]$ hadoop fs -ls /user/oozie/share/lib

Found 3 items

drwxr-xr-x   - oozie hdfs          0 2015-07-26 09:41
/user/oozie/share/lib/launcher_20150726094136

drwxr-xr-x   - oozie hdfs          0 2015-07-26 10:40
/user/oozie/share/lib/launcher_20150726104031

drwxr-xr-x   - oozie hdfs          0 2015-06-05 09:19
/user/oozie/share/lib/lib_20150605091901


Since from Hue the job submission is via hue user. I also copied the same
to hue user path.

But still job is in pending state. I tried both Pig and Hive

[hue@sandbox oozie]$ hadoop fs -ls /user/hue/share/lib

Found 3 items

drwxr-xr-x   - hue hdfs          0 2015-07-26 10:46
/user/hue/share/lib/launcher_20150726094136

drwxr-xr-x   - hue hdfs          0 2015-07-26 10:46
/user/hue/share/lib/launcher_20150726104031

drwxr-xr-x   - hue hdfs          0 2015-07-26 10:47
/user/hue/share/lib/lib_20150605091901

[hue@sandbox oozie]$



In oozie-audit.log

I can see


ame=hue&doAs=admin]

2015-07-26 10:42:37,787  INFO oozieaudit:520 - IP [127.0.0.1], USER [hue],
GROUP [null], APP [Pig_Replace_Delimiter], JOBID
[0000000-150726104026468-oozie-oozi-W], OPERATION [start], PARAMETER
[0000000-150726104026468-oozie-oozi-W], STATUS [SUCCESS], HTTPCODE [200],
ERRORCODE [null], ERRORMESSAGE [null]

2015-07-26 10:48:45,470  INFO oozieaudit:520 - IP [127.0.0.1], USER [hue],
GROUP [null], APP [Pig_Replace_Delimiter], JOBID
[0000001-150726104026468-oozie-oozi-W], OPERATION [start], PARAMETER
[0000001-150726104026468-oozie-oozi-W], STATUS [SUCCESS], HTTPCODE [200],
ERRORCODE [null], ERRORMESSAGE [null]


In Oozie log i can see

*$ oozie job -oozie http://localhost:11000/oozie
<http://localhost:11000/oozie>  -log 0000001-150726104026468-oozie-oozi-W*

[hue@sandbox logs]$ oozie job -oozie http://localhost:11000/oozie  -log
0000001-150726104026468-oozie-oozi-W

2015-07-26 10:48:45,371  INFO ActionStartXCommand:520 - SERVER[
sandbox.hortonworks.com] USER[hue] GROUP[-] TOKEN[]
APP[Pig_Replace_Delimiter] JOB[0000001-150726104026468-oozie-oozi-W]
ACTION[0000001-150726104026468-oozie-oozi-W@:start:] Start action
[0000001-150726104026468-oozie-oozi-W@:start:] with user-retry state :
userRetryCount [0], userRetryMax [0], userRetryInterval [10]

2015-07-26 10:48:45,377  INFO ActionStartXCommand:520 - SERVER[
sandbox.hortonworks.com] USER[hue] GROUP[-] TOKEN[]
APP[Pig_Replace_Delimiter] JOB[0000001-150726104026468-oozie-oozi-W]
ACTION[0000001-150726104026468-oozie-oozi-W@:start:]
[***0000001-150726104026468-oozie-oozi-W@:start:***]Action status=DONE

2015-07-26 10:48:45,377  INFO ActionStartXCommand:520 - SERVER[
sandbox.hortonworks.com] USER[hue] GROUP[-] TOKEN[]
APP[Pig_Replace_Delimiter] JOB[0000001-150726104026468-oozie-oozi-W]
ACTION[0000001-150726104026468-oozie-oozi-W@:start:]
[***0000001-150726104026468-oozie-oozi-W@:start:***]Action updated in DB!

2015-07-26 10:48:45,471  INFO WorkflowNotificationXCommand:520 - SERVER[
sandbox.hortonworks.com] USER[-] GROUP[-] TOKEN[-] APP[-]
JOB[0000001-150726104026468-oozie-oozi-W]
ACTION[0000001-150726104026468-oozie-oozi-W@:start:] No Notification URL is
defined. Therefore nothing to notify for job
0000001-150726104026468-oozie-oozi-W@:start:

2015-07-26 10:48:45,478  INFO WorkflowNotificationXCommand:520 - SERVER[
sandbox.hortonworks.com] USER[-] GROUP[-] TOKEN[-] APP[-]
JOB[0000001-150726104026468-oozie-oozi-W] ACTION[] No Notification URL is
defined. Therefore nothing to notify for job
0000001-150726104026468-oozie-oozi-W

2015-07-26 10:48:45,492  INFO ActionStartXCommand:520 - SERVER[
sandbox.hortonworks.com] USER[hue] GROUP[-] TOKEN[]
APP[Pig_Replace_Delimiter] JOB[0000001-150726104026468-oozie-oozi-W]
ACTION[0000001-150726104026468-oozie-oozi-W@pig-5839] Start action
[0000001-150726104026468-oozie-oozi-W@pig-5839] with user-retry state :
userRetryCount [0], userRetryMax [0], userRetryInterval [10]

[hue@sandbox logs]$


I am using default settings for VM without any changes.

Any help would be appreciated.

Mime
View raw message