hadoop-mapreduce-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vandana kumari <kvandana1...@gmail.com>
Subject Re: Mapreduce job got stuck
Date Thu, 16 Apr 2015 14:58:47 GMT
Thank you everyone for your reply. My problem is solved now.

On Wed, Apr 15, 2015 at 4:39 PM, Rohith Sharma K S <
rohithsharmaks@huawei.com> wrote:

>  Hi,
>
>
>
> On master machine, NodeManager is not running because of “Caused by:
> java.net.BindException: Problem binding to [*kirti:8040*], got from logs.
>
>
>
> The port 8040 is in use!!! Configure available port number.
>
>
>
>
>
> Thanks & Regards
>
> Rohith Sharma K S
>
>
>
> *From:* Vandana kumari [mailto:kvandana1992@gmail.com]
> *Sent:* 15 April 2015 16:29
> *To:* user@hadoop.apache.org; Rohith Sharma K S
> *Subject:* Re: Mapreduce job got stuck
>
>
>
> When i made the changes as specified by Rohith, my job is running but it
> runs only on slave nodes(amit & yashbir) not on master node(kirti) and
> still no nodemanager is running on master node.
>
>
>
> On Wed, Apr 15, 2015 at 6:39 AM, Vandana kumari <kvandana1992@gmail.com>
> wrote:
>
> i had attached nodemanager log of master file and modified yarn-site.xml
> file
>
>
>
> On Wed, Apr 15, 2015 at 6:21 AM, Rohith Sharma K S <
> rohithsharmaks@huawei.com> wrote:
>
> Hi Vandana
>
>
>
> From the configurations, it looks like none of the NodeManagers are
> registered with RM because of configuration “*yarn.resourcemanager.resource-
> tracker.address*” issue.  May be you can confirm any NM’s are registered
> with RM.
>
>
>
> In the below, there is space after “*resource-“ but “resource-tracker” *is
> single without any space. Check after removing space.
>
> *<name>yarn.resourcemanager.resource- tracker.address</name>*
>
>
>
> *Similarly I see same issue in “yarn.nodemanager.aux-
> services.mapreduce.shuffle.class” where space after “aux-”!!!*
>
>
>
> *Hope it helps you to resolve issue*
>
>
>
> Thanks & Regards
>
> Rohith Sharma K S
>
>
>
> *From:* Vandana kumari [mailto:kvandana1992@gmail.com]
> *Sent:* 15 April 2015 15:33
> *To:* user@hadoop.apache.org
> *Subject:* Mapreduce job got stuck
>
>
>
> i had setup a 3 node hadoop cluster on centos 6.5 but nodemanager is not
> running on master and is running on slave nodes. Alse when i submit a job
> then job get stuck. the same job runs well on sinle node setup. I am unable
> to figure out the problem. Attaching all the configuration files.
>
> Any help will be highly appreciated.
>
>
> --
>
> Thanks and regards
>
>   Vandana kumari
>
>
>
>
> --
>
> Thanks and regards
>
>   Vandana kumari
>
>
>
>
> --
>
> Thanks and regards
>
>   Vandana kumari
>



-- 
Thanks and regards
  Vandana kumari

Mime
View raw message