hadoop-mapreduce-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Susheel Kumar Gadalay <skgada...@gmail.com>
Subject Re: Running job issues
Date Wed, 27 Aug 2014 07:28:04 GMT
You have to use this command to format

hdfs namenode –format

not hdfs dfs -format

On 8/27/14, Blanca Hernandez <Blanca.Hernandez@willhaben.at> wrote:
> Hi, thanks for your answers.
>
> Sorry, I forgot to add it, I couldn´t run the command neither:
>
> C:\development\tools\hadoop>%HADOOP_PREFIX%\bin\hdfs dfs -format
> -format: Unknown command
>
> C:\development\tools\hadoop>echo %HADOOP_PREFIX%
> C:\development\tools\hadoop
>
> By using –help command there is no format param.
> My Hadoop version: 2.4.0 (the latest version supported by mongo-hadoop).
>
> Best regards,
>
> Blanca
>
>
> Von: Arpit Agarwal [mailto:aagarwal@hortonworks.com]
> Gesendet: Dienstag, 26. August 2014 21:39
> An: user@hadoop.apache.org
> Betreff: Re: Running job issues
>
>> And the namenode does not even start: 14/08/26 12:01:09 WARN
>> namenode.FSNamesystem: Encountered exception loading fsimage
>> java.io.IOException: NameNode is not formatted.
>
> Have you formatted HDFS (step 3.4)?
>
> On Tue, Aug 26, 2014 at 3:08 AM, Blanca Hernandez
> <Blanca.Hernandez@willhaben.at<mailto:Blanca.Hernandez@willhaben.at>>
> wrote:
> Hi!
>
> I have just installed hadoop in my windows x64 machine.l followd carefully
> the instructions in https://wiki.apache.org/hadoop/Hadoop2OnWindows but in
> the
> 3.5<https://wiki.apache.org/hadoop/Hadoop2OnWindows%20but%20in%20the%203.5>
> and 3.6 points I have some problems I can not handle.
>
> %HADOOP_PREFIX%\sbin\start-dfs.cmd
>
>
> The datanode can no connect: 14/08/26 12:01:30 WARN datanode.DataNode:
> Problem connecting to server:
> 0.0.0.0/0.0.0.0:19000<http://0.0.0.0/0.0.0.0:19000>
> And the namenode does not even start: 14/08/26 12:01:09 WARN
> namenode.FSNamesystem: Encountered exception loading fsimage
> java.io.IOException: NameNode is not formatted.
>
> Trying to get running the mapreduce-example indicated in the pont 3.6, I get
> the connection exception again. Tha brings me to the
> http://wiki.apache.org/hadoop/ConnectionRefused page where the exception in
> explained. So I guess I have some misunderstandings with the configuration.
> I tried to find information about that and found the page
> http://wiki.apache.org/hadoop/HowToConfigure but is still not very clear for
> me.
>
> I attach my config files, the ones I modified maybe you can help me out…
>
> Many thanks!!
>
>
> CONFIDENTIALITY NOTICE
> NOTICE: This message is intended for the use of the individual or entity to
> which it is addressed and may contain information that is confidential,
> privileged and exempt from disclosure under applicable law. If the reader of
> this message is not the intended recipient, you are hereby notified that any
> printing, copying, dissemination, distribution, disclosure or forwarding of
> this communication is strictly prohibited. If you have received this
> communication in error, please contact the sender immediately and delete it
> from your system. Thank You.
>

Mime
View raw message