hadoop-mapreduce-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stanley Shi <s...@gopivotal.com>
Subject Re:
Date Thu, 06 Mar 2014 08:20:11 GMT
Maybe your console and browser are using different settings, would you
please try "wget
http://repo.maven.apache.org/maven2/org/apache/felix/maven-bundle-plugin/2.4.0/maven-bundle-plugin-2.4.0.pom
"?

Regards,
*Stanley Shi,*



On Wed, Mar 5, 2014 at 6:59 PM, Avinash Kujur <avinz50@gmail.com> wrote:

> yes ming.
>
>
> On Wed, Mar 5, 2014 at 2:56 AM, Mingjiang Shi <mshi@gopivotal.com> wrote:
>
>> Can you access this link?
>>
>> http://repo.maven.apache.org/maven2/org/apache/felix/maven-bundle-plugin/2.4.0/maven-bundle-plugin-2.4.0.pom
>>
>>
>> On Wed, Mar 5, 2014 at 6:54 PM, Avinash Kujur <avinz50@gmail.com> wrote:
>>
>>> if i follow repo.maven.apache.org link on my url, it is showing this
>>> message :
>>>
>>> Browsing for this directory has been disabled.
>>>
>>> View <http://search.maven.org/#browse> this directory's contents on
>>> http://search.maven.org <http://search.maven.org/#browse> instead.
>>>
>>> so how can i change the link from repo.maven.apache .org to
>>> http://search.maven.org ?
>>>
>>>
>>> On Wed, Mar 5, 2014 at 2:49 AM, Avinash Kujur <avinz50@gmail.com> wrote:
>>>
>>>> yes. it has internet access.
>>>>
>>>>
>>>> On Wed, Mar 5, 2014 at 2:47 AM, Mingjiang Shi <mshi@gopivotal.com>wrote:
>>>>
>>>>> see the error message:
>>>>>
>>>>> Unknown host repo.maven.apache.org -> [Help 2]
>>>>>
>>>>>
>>>>> Does your machine has internet access?
>>>>>
>>>>>
>>>>> On Wed, Mar 5, 2014 at 6:42 PM, Avinash Kujur <avinz50@gmail.com>wrote:
>>>>>
>>>>>> home/cloudera/ contains hadoop files.
>>>>>>
>>>>>>
>>>>>> On Wed, Mar 5, 2014 at 2:40 AM, Avinash Kujur <avinz50@gmail.com>wrote:
>>>>>>
>>>>>>> [cloudera@localhost hadoop-common-trunk]$ mvn clean install
>>>>>>> -DskipTests -Pdist
>>>>>>> [INFO] Scanning for projects...
>>>>>>> Downloading:
>>>>>>> http://repo.maven.apache.org/maven2/org/apache/felix/maven-bundle-plugin/2.4.0/maven-bundle-plugin-2.4.0.pom
>>>>>>> [ERROR] The build could not read 1 project -> [Help 1]
>>>>>>> [ERROR]
>>>>>>> [ERROR]   The project org.apache.hadoop:hadoop-main:3.0.0-SNAPSHOT
>>>>>>> (/home/cloudera/hadoop-common-trunk/pom.xml) has 1 error
>>>>>>> [ERROR]     Unresolveable build extension: Plugin
>>>>>>> org.apache.felix:maven-bundle-plugin:2.4.0 or one of its dependencies
could
>>>>>>> not be resolved: Failed to read artifact descriptor for
>>>>>>> org.apache.felix:maven-bundle-plugin:jar:2.4.0: Could not transfer
artifact
>>>>>>> org.apache.felix:maven-bundle-plugin:pom:2.4.0 from/to central
(
>>>>>>> http://repo.maven.apache.org/maven2): repo.maven.apache.org:
>>>>>>> Unknown host repo.maven.apache.org -> [Help 2]
>>>>>>>
>>>>>>> [ERROR]
>>>>>>> [ERROR] To see the full stack trace of the errors, re-run Maven
with
>>>>>>> the -e switch.
>>>>>>> [ERROR] Re-run Maven using the -X switch to enable full debug
>>>>>>> logging.
>>>>>>> [ERROR]
>>>>>>> [ERROR] For more information about the errors and possible
>>>>>>> solutions, please read the following articles:
>>>>>>>  [ERROR] [Help 1]
>>>>>>> http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
>>>>>>> [ERROR] [Help 2]
>>>>>>> http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException
>>>>>>>
>>>>>>>
>>>>>>> when i execute this command from hadoop directory this is the
error
>>>>>>> i am getting.
>>>>>>>
>>>>>>>
>>>>>>> On Wed, Mar 5, 2014 at 2:33 AM, Mingjiang Shi <mshi@gopivotal.com>wrote:
>>>>>>>
>>>>>>>> Did you execute the command from /home/cloudera? Does it
contains
>>>>>>>> the hadoop source code? You need to execute the command from
the source
>>>>>>>> code directory.
>>>>>>>>
>>>>>>>>
>>>>>>>> On Wed, Mar 5, 2014 at 6:28 PM, Avinash Kujur <avinz50@gmail.com>wrote:
>>>>>>>>
>>>>>>>>> when i am using this command
>>>>>>>>> mvn clean install -DskipTests -Pdist
>>>>>>>>>
>>>>>>>>> its giving this error:
>>>>>>>>>
>>>>>>>>> [cloudera@localhost ~]$ mvn clean install -DskipTests
-Pdist
>>>>>>>>> [INFO] Scanning for projects...
>>>>>>>>> [INFO]
>>>>>>>>> ------------------------------------------------------------------------
>>>>>>>>> [INFO] BUILD FAILURE
>>>>>>>>> [INFO]
>>>>>>>>> ------------------------------------------------------------------------
>>>>>>>>> [INFO] Total time: 0.170 s
>>>>>>>>> [INFO] Finished at: 2014-03-05T02:25:52-08:00
>>>>>>>>> [INFO] Final Memory: 2M/43M
>>>>>>>>> [INFO]
>>>>>>>>> ------------------------------------------------------------------------
>>>>>>>>> [WARNING] The requested profile "dist" could not be activated
>>>>>>>>> because it does not exist.
>>>>>>>>> [ERROR] The goal you specified requires a project to
execute but
>>>>>>>>> there is no POM in this directory (/home/cloudera). Please
verify you
>>>>>>>>> invoked Maven from the correct directory. -> [Help
1]
>>>>>>>>> [ERROR]
>>>>>>>>> [ERROR] To see the full stack trace of the errors, re-run
Maven
>>>>>>>>> with the -e switch.
>>>>>>>>> [ERROR] Re-run Maven using the -X switch to enable full
debug
>>>>>>>>> logging.
>>>>>>>>> [ERROR]
>>>>>>>>> [ERROR] For more information about the errors and possible
>>>>>>>>> solutions, please read the following articles:
>>>>>>>>> [ERROR] [Help 1]
>>>>>>>>> http://cwiki.apache.org/confluence/display/MAVEN/MissingProjectException
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> help me out.
>>>>>>>>> Thanks in advance. :)
>>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> --
>>>>>>>> Cheers
>>>>>>>> -MJ
>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> Cheers
>>>>> -MJ
>>>>>
>>>>
>>>>
>>>
>>
>>
>> --
>> Cheers
>> -MJ
>>
>
>

Mime
View raw message