hadoop-mapreduce-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sam liu <samliuhad...@gmail.com>
Subject How to submit the patch MAPREDUCE-4490.patch which works for branch-1.2, not trunk?
Date Fri, 14 Feb 2014 06:50:49 GMT
Hi Experts,

I have been working on the JIRA
https://issues.apache.org/jira/browse/MAPREDUCE-4490 and attached
MAPREDUCE-4490.patch which could fix this jira. I would like to contribute
my patch to community, but encountered some issues.

MAPREDUCE-4490 is an issue on Hadoop-1.x versions, and my patch based on
the  latest code of origin/branch-1.2. However, current trunk bases on Yarn
and does not has such issue any more. So my patch could not be applied on
current trunk code, and it's actually no need to generate a similar patch
on trunk at all.

How to submit the patch MAPREDUCE-4490.patch only to origin/branch-1.2, not
trunk? Is it allowed by Apache Hadoop?

Thanks!

Mime
View raw message