hadoop-mapreduce-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dhanasekaran Anbalagan <bugcy...@gmail.com>
Subject Hadoop-streaming : PYTHONPATH not working when mapper runs
Date Thu, 09 Jan 2014 00:53:39 GMT
Hi Guys,

I have problem when I ran hadoop streaming PYTHONPATH environment variable
not properly getting value. when I try to extend sys.path code level  not
working. It's says KeyError:'PYTHONPATH' In my case I already exported
PYTHONPATH in /etc/bashrc

mapper logs:
stderr logs
Traceback (most recent call last):
line 14, in <module>
*    sys.path.extend(os.environ['PYTHONPATH'].split(os.path.pathsep))*
  File "/usr/lib/python2.7/UserDict.py", line 23, in __getitem__
    raise KeyError(key)
*KeyError: 'PYTHONPATH'*

I tried /etc/sudoers file I added PYTHONPATH

Defaults        env_keep ="PYTHONPATH"

also not working.

can you please guide me How to fix this.


Did I learn something today? If not, I wasted it.

View raw message