hadoop-mapreduce-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jiayu Ji <jiayu...@gmail.com>
Subject Re: issue when using HDFS
Date Mon, 16 Dec 2013 15:51:47 GMT
It is possible that your datanode daemon has not started yet. Logon to the
datanode and check if the daemon is running by issue a jps command.

Another possible reason is that your namenode can not communicate with
datanode. Try ping datanode from the namenode.

The log files are supposed in HADOOP_HOME/logs by default.


On Mon, Dec 16, 2013 at 5:18 AM, Geelong Yao <geelongyao@gmail.com> wrote:

> where should I find this logs?
> I think the problem mainly on slaves,where should I find the logs?
>
>
> 2013/12/16 shashwat shriparv <dwivedishashwat@gmail.com>
>
>> Had your upgrade finished successfully?? check if datanode is able to
>> connect to namenode, check datanode logs and please attach some log here if
>> you are getting any error in if data node is running.
>>
>>
>>
>> *Warm Regards_**∞_*
>> *Shashwat Shriparv*
>> Big-Data Engineer(HPC)
>> [image: http://www.linkedin.com/pub/shashwat-shriparv/19/214/2a9]<http://www.linkedin.com/pub/shashwat-shriparv/19/214/2a9>[image:
>> https://twitter.com/shriparv] <https://twitter.com/shriparv>[image:
>> https://www.facebook.com/shriparv] <https://www.facebook.com/shriparv>[image:
>> http://google.com/+ShashwatShriparv]<http://google.com/+ShashwatShriparv>[image:
>> http://www.youtube.com/user/sShriparv/videos]<http://www.youtube.com/user/sShriparv/videos>[image:
>> http://profile.yahoo.com/SWXSTW3DVSDTF2HHSRM47AV6DI/]<shriparv@yahoo.com>
>>
>>
>>
>>
>> On Mon, Dec 16, 2013 at 4:04 PM, Geelong Yao <geelongyao@gmail.com>wrote:
>>
>>> Now the datanode is not working
>>> [image: 内嵌图片 1]
>>>
>>>
>>> 2013/12/16 Geelong Yao <geelongyao@gmail.com>
>>>
>>>> it is the namenode's problem.
>>>> How can I fix this problem?
>>>>
>>>>
>>>>
>>>> 2013/12/16 Shekhar Sharma <shekhar2581@gmail.com>
>>>>
>>>>> Seems like DataNode is not running or went dead
>>>>> Regards,
>>>>> Som Shekhar Sharma
>>>>> +91-8197243810
>>>>>
>>>>>
>>>>> On Mon, Dec 16, 2013 at 1:40 PM, Geelong Yao <geelongyao@gmail.com>
>>>>> wrote:
>>>>> > Hi Everyone
>>>>> >
>>>>> > After I upgrade the hadoop to CDH 4.2.0 Hadoop 2.0.0,I try to
>>>>> running some
>>>>> > test
>>>>> > When I try to upload file to HDFS,error comes:
>>>>> >
>>>>> >
>>>>> >
>>>>> > node32:/software/hadoop-2.0.0-cdh4.2.0 # hadoop dfs -put
>>>>> > /public/data/carinput1G_BK carinput1G
>>>>> > DEPRECATED: Use of this script to execute hdfs command is deprecated.
>>>>> > Instead use the hdfs command for it.
>>>>> >
>>>>> > ls: Call From node32/11.11.11.32 to node32:9000 failed on connection
>>>>> > exception: java.net.ConnectException: Connection refused; For more
>>>>> details
>>>>> > see:  http://wiki.apache.org/hadoop/ConnectionRefused
>>>>> >
>>>>> >
>>>>> >
>>>>> > Something wrong with my setting?
>>>>> >
>>>>> > BRs
>>>>> > Geelong
>>>>> >
>>>>> >
>>>>> > --
>>>>> > From Good To Great
>>>>>
>>>>
>>>>
>>>>
>>>> --
>>>> From Good To Great
>>>>
>>>
>>>
>>>
>>> --
>>> From Good To Great
>>>
>>
>>
>
>
> --
> From Good To Great
>



-- 
Jiayu (James) Ji,

Cell: (312)823-7393

Mime
View raw message