hadoop-mapreduce-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Silvina Caíno Lores <silvi.ca...@gmail.com>
Subject Re: Ant BuildException error building Hadoop 2.2.0
Date Thu, 05 Dec 2013 07:52:52 GMT
Hi again,

I've tried to build using JDK 1.6.0_38 and I'm still getting the same
exception:

~/hadoop-2.2.0-maven$ java -version
java version "1.6.0_38-ea"
Java(TM) SE Runtime Environment (build 1.6.0_38-ea-b04)
Java HotSpot(TM) 64-Bit Server VM (build 20.13-b02, mixed mode)

------

[ERROR] Failed to execute goal
org.apache.maven.plugins:maven-antrun-plugin:1.7:run (make) on project
hadoop-common: An Ant BuildException has occured: exec returned: 1
[ERROR] around Ant part ...<exec
dir="/home/scaino/hadoop-2.2.0-maven/hadoop-common-project/hadoop-common/target/native"
executable="cmake" failonerror="true">... @ 4:135 in
/home/scaino/hadoop-2.2.0-maven/hadoop-common-project/hadoop-common/target/antrun/build-main.xml


May it be a missing dependency? Do you know how can I check the plugin
actually exists using Maven?

Thanks!


On 4 December 2013 20:23, java8964 <java8964@hotmail.com> wrote:

> Can you try JDK 1.6?
>
> I just did a Hadoop 2.2.0 GA release build myself days ago. From my
> experience, JDK 1.7 not work for me.
>
> Yong
>
> ------------------------------
> Date: Wed, 4 Dec 2013 19:55:16 +0100
> Subject: Re: Ant BuildException error building Hadoop 2.2.0
>
> From: silvi.caino@gmail.com
> To: user@hadoop.apache.org
>
> Hi,
>
> It seems I do:
>
> ~/hadoop-2.2.0-maven$ cmake --version
> cmake version 2.8.2
>
>
>
> On 4 December 2013 19:51, java8964 <java8964@hotmail.com> wrote:
>
> Do you have 'cmake' in your environment?
>
> Yong
>
> ------------------------------
> Date: Wed, 4 Dec 2013 17:20:03 +0100
> Subject: Ant BuildException error building Hadoop 2.2.0
> From: silvi.caino@gmail.com
> To: user@hadoop.apache.org
>
>
> Hello everyone,
>
> I've been having trouble to build Hadoop 2.2.0 using Maven 3.1.1, this is
> part of the output I get (full log at http://pastebin.com/FE6vu46M):
>
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Summary:
> [INFO]
> [INFO] Apache Hadoop Main ................................ SUCCESS
> [27.471s]
> [INFO] Apache Hadoop Project POM ......................... SUCCESS [0.936s]
> [INFO] Apache Hadoop Annotations ......................... SUCCESS [3.819s]
> [INFO] Apache Hadoop Assemblies .......................... SUCCESS [0.414s]
> [INFO] Apache Hadoop Project Dist POM .................... SUCCESS [1.834s]
> [INFO] Apache Hadoop Maven Plugins ....................... SUCCESS [4.693s]
> [INFO] Apache Hadoop MiniKDC ............................. SUCCESS [4.346s]
> [INFO] Apache Hadoop Auth ................................ SUCCESS [4.923s]
> [INFO] Apache Hadoop Auth Examples ....................... SUCCESS [2.797s]
> [INFO] Apache Hadoop Common .............................. FAILURE
> [22.898s]
> [INFO] Apache Hadoop NFS ................................. SKIPPED
>
> ..........
>
> [INFO]
> ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: 1:17.655s
> [INFO] Finished at: Wed Dec 04 16:18:31 CET 2013
> [INFO] Final Memory: 64M/420M
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-antrun-plugin:1.7:run (make) on project
> hadoop-common: An Ant BuildException has occured: exec returned: 1
> [ERROR] around Ant part ...<exec
> dir="/home/scaino/hadoop-2.2.0-maven/hadoop-common-project/hadoop-common/target/native"
> executable="cmake" failonerror="true">... @ 4:135 in
> /home/scaino/hadoop-2.2.0-maven/hadoop-common-project/hadoop-common/target/antrun/build-main.xml
>
>
> I've checked Protoc and it seems to be working, same with the library
> path, which is pointing to the libraries (installed in $HOME/install/lib):
>
> ~/hadoop-2.2.0-maven$ protoc --version
> libprotoc 2.5.0
>
> ~/hadoop-2.2.0-maven$ echo $LD_LIBRARY_PATH
>
> /home/scaino/install/lib:/home/software/gcc-4.8/lib64:/home/software/mpich2-1.2.1/lib
>
>
> This is some system information retrieved by Maven:
>
> ~/hadoop-2.2.0-maven$ mvn --version
> Apache Maven 3.1.1 (0728685237757ffbf44136acec0402957f723d9a; 2013-09-17
> 17:22:22+0200)
> Maven home: /home/scaino/apache-maven-3.1.1
> Java version: 1.7.0_25, vendor: Oracle Corporation
> Java home: /home/software/jdk1.7.0_25/jre
> Default locale: es_ES, platform encoding: UTF-8
> OS name: "linux", version: "2.6.35-32-server", arch: "amd64", family:
> "unix"
>
>
> I would appreciate any guidelines or hints that could make me understand
> what is going on since anything I've tried or seen has worked so far.
>
> Thanks a lot in advance.
>
> Regards,
> Silvina Caíno
>
>
>
>
>
>

Mime
View raw message