hadoop-mapreduce-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From MONTMORY Alain <alain.montm...@thalesgroup.com>
Subject RE: Good resource to learn .20 API?
Date Wed, 08 Feb 2012 15:51:04 GMT
Hello,

I Have the same question at the begining of year 2010 when we start using Hadoop...and we
start using NewApi as the old ones are marked depreaceted...

And we spent lot of time using NewApi because not all the feature are not ported in the NewApi
(MultipleInputFormat for example..).

Following Todd Lipcon advice we start using "Old Api" (which are not so depreaceated according
to him..) and since this decision we have not seen an inconvenient using old Api...

This is my modest opinion...

Regards

Alain

[@@THALES GROUP RESTRICTED@@]


-----Message d'origine-----
De : Keith Wiley [mailto:kwiley@keithwiley.com] 
Envoyé : mercredi 8 février 2012 16:33
À : mapreduce-user@hadoop.apache.org
Objet : Re: Good resource to learn .20 API?

Thanks!  I'll look over those slides in detail, but at a first glance, they doesn't appear
to draw a final conclusion on the matter (and they're from 2009)...so, to put it bluntly,
which API is the recommended usage at this point?  .20 was supposed to make it easier for
maintainers of Hadoop to extend, but I'm not aware that it was ever considered to offer major
advantages from the users point of view.  So for a *user*, is there any advantage to using
the .20 API, especially given that one of the most popular books (hint hint) is still only
available in a .19 version?

(I'm aware of the upcoming May 3rd edition), but I can't wait until then, I've got work to
do and have not found good resources for learning .20, unless it really isn't more complicated
than a could of slides worth of material.

I don't mean to sound antagonistic, I just want to know which API is *recommended* for a new
project, not something old that is already embedded in one API or the other?

Thanks.

On Feb 7, 2012, at 20:04 , Harsh J wrote:

> Hey Keith,
> 
> The new API is still unstable, and we continue to support the 0.19
> stable (old) API even in 0.23, but here is a good guide:
> http://www.slideshare.net/sh1mmer/upgrading-to-the-new-map-reduce-api
> [The first part, from Owen]


________________________________________________________________________________
Keith Wiley     kwiley@keithwiley.com     keithwiley.com    music.keithwiley.com

"I do not feel obliged to believe that the same God who has endowed us with
sense, reason, and intellect has intended us to forgo their use."
                                           --  Galileo Galilei
________________________________________________________________________________


Mime
View raw message