hadoop-mapreduce-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Luya <alexander.l...@gmail.com>
Subject hadoop branch-0.20-append Build error:build.xml:933: exec returned: 1
Date Tue, 12 Apr 2011 02:45:37 GMT
BUILD FAILED
......./branch-0 .20-append/build.xml:927: The following error
occurred while executing this line:
....../branch-0 .20-append/build.xml:933: exec returned: 1

Total time: 1 minute 17 seconds
+ RESULT=1
+ '[' 1 '!=' 0 ']'
+ echo 'Build Failed: 64-bit build not run'
Build Failed: 64-bit build not run
+ exit 1
-----------------------------------------------------------------------------------------------------------------
I checked content in file build.xml:
------------------------------------------------------------------------------------------------------------
line 927:<antcall target="cn-docs"/></target><target name="cn-docs"
depends="forrest.check, init" description="Generate forrest-based
Chinese documentation. To use, specify -Dforrest.home=&lt;base of Apache
Forrest installation&gt; on the command line." if="forrest.home">
line 933:<exec dir="${src.docs.cn}"
executable="${forrest.home}/bin/forrest" failonerror="true">
-----------------------------------------------------------------------------------------------------------------------------------------------
It seems try to execute forrest,what is the problem here?I am running a
64bit ubuntu,with 64+32bit-jdk-1.6 and 64-bit-jdk-1.5  installed.Some
guys told there are some tricks in this
page:http://wiki.apache.org/hadoop/HowToRelease  to get forrest build to
work.But I can't find any tricks in the page.
Any help is appreciated.



Mime
View raw message