hadoop-mapreduce-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From li ping <li.j...@gmail.com>
Subject Re: Starting a Hadoop job programtically
Date Thu, 25 Nov 2010 08:44:04 GMT
But I can run the application on the hadoop server. (not use the hadoop
command to run).



On Thu, Nov 25, 2010 at 4:38 PM, Jeff Zhang <zjffdu@gmail.com> wrote:

> Please check the status of job tracker since you can not find port
> 9001 using netstat
>
>
>
> 2010/11/25 li ping <li.j2ee@gmail.com>:
> > Hi:
> > I am trying to run a job in my own application.
> > So far, I can run the job on the server which the hadoop server is
> running
> > on.
> > But what I expect is the hadoop server is running on server A. and the
> > application will run on other server (B server).
> > If I run the application on Server B, it will throw some error, see blow:
> > 10/11/25 15:54:10 INFO ipc.Client: Retrying connect to server:
> > xi-pli/xxx.xxx.xxx.xxx:9001. Already tried 0 time(s).
> > 10/11/25 15:54:11 INFO ipc.Client: Retrying connect to
> > server: xi-pli/xxx.xxx.xxx.xxx:9001. Already tried 1 time(s).
> > 10/11/25 15:54:12 INFO ipc.Client: Retrying connect to
> > server: xi-pli/xxx.xxx.xxx.xxx:9001. Already tried 2 time(s).
> > ...........
> > Here I replace the real ip address with the xxx.xxx.xxx.xxx.
> > This is my configuration file:
> > <configuration>
> >     <property>
> >       <name>fs.default.name</name>
> >       <value>hdfs://xi-pli:9000</value>
> >       <description></description>
> >     </property>
> > <property>
> >   <name>mapred.job.tracker</name>
> >   <value>xi-pli:9001</value>
> >   <description></description>
> > </property>
> > </configuration>
> > The configuration file on server side is almost the same.
> > The server A and B can ping each other. and Also can ssh to each other
> > without the password.
> > The A,B server has the same username "hadoop"
> > The iptable also has been shutdown.
> > I can use the "telnet" command to connect to 9001 port on hadoop server
> > (Server A). but on Server B, I can't telnet to Server A.(The hadoop
> server
> > is running on Server A )
> > If I use the netstat -a to check the port. I can't find the 9001 port.
> > I have no idea why I can't run the job on the other server. If anyone can
> > give me some suggestion, that's very appreciated.
> > Thanks
> > Best Regards
> > --
> > -----李平
> > --
> > -----李平
> >
>
>
>
> --
> Best Regards
>
> Jeff Zhang
>



-- 
-----李平

Mime
View raw message