hadoop-mapreduce-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Todd Lipcon <t...@cloudera.com>
Subject Re: compiling hadoop?
Date Thu, 10 Dec 2009 23:47:57 GMT
Hi Calvin,

In order to compile hadoop, you need a net connection to download its
dependencies.

One thing you can do is to compile it on another machine, and then
rsync your ~/.ivy2/cache directory from that machine to the machine
you'll primarily be developing on.

Hope that helps
-Todd

On Thu, Dec 10, 2009 at 3:37 PM, Calvin <calvin.lists@gmail.com> wrote:
> Please direct me to a different forum if I am in the wrong place.
> I am just trying to compile Hadoop out of the box ...
> I first download hadoop-0.20.1 and untar it.  Next, I run $ANT_HOME/bin/ant,
> only to get stuck at:
> ivy-download:
>       [get] Getting:
> http://repo2.maven.org/maven2/org/apache/ivy/ivy/2.0.0-rc2/ivy-2.0.0-rc2.jar
>       [get] To: /xxx/hadoop-0.20.1/ivy/ivy-2.0.0-rc2.jar
> (no wide area connection on the machine I am building on).  However, this
> jar file already exists!  So, I tried to comment out the "get" line
> in"ivy-download" target in my build.xml.  Now I get stuck on:
> ivy-resolve-common:
> [ivy:resolve] :: resolving dependencies ::
> org.apache.hadoop#Hadoop;working@myhostname.com
> [ivy:resolve]   confs: [common]
>
> I'm using ant 1.7.0.
> Any help/pointers/resources would be greatly appreciated.
> Thank you!
> -Calvin

Mime
View raw message