hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andras Bokor (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MAPREDUCE-6814) mapred's FileAlreadyExistsException should be deprecated in favor of hadoop-common's one.
Date Fri, 24 Feb 2017 15:53:44 GMT

     [ https://issues.apache.org/jira/browse/MAPREDUCE-6814?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andras Bokor updated MAPREDUCE-6814:
------------------------------------
    Description: 
Mapred's FileAlreadyExistsException was deprecated with MAPREDUCE-963 but later on it was
un-deprecate with MAPREDUCE-1735/MAPREDUCE-3771 accidentally.
It think it was un-deprecate by mistake:
# MAPREDUCE-963 deprecate FAEE
# Later on the whole Mapreduce 1 API was deprecated
# By MAPREDUCE-1735/MAPREDUCE-3771 Mapred 1 API (including FAEE) was un-deprecated.
Since FAEE was deprecated regardless of point 2 it shouldn't have been un-deprecated.


  was:
Mapred's FileAlreadyExistsException was deprecated with MAPREDUCE-963 but later on it was
un-deprecate with MAPREDUCE-1735/MAPREDUCE-3771.
It think it was un-deprecate by mistake:
# MAPREDUCE-963 deprecate FAEE
# Later on the whole Mapreduce 1 API was deprecated
# By MAPREDUCE-1735/MAPREDUCE-3771 Mapred 1 API (including FAEE) was un-deprecated.
Since FAEE was deprecated regardless of point 2 it shouldn't have been un-deprecated.



> mapred's FileAlreadyExistsException should be deprecated in favor of hadoop-common's
one.
> -----------------------------------------------------------------------------------------
>
>                 Key: MAPREDUCE-6814
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-6814
>             Project: Hadoop Map/Reduce
>          Issue Type: Improvement
>            Reporter: Andras Bokor
>            Assignee: Andras Bokor
>            Priority: Minor
>
> Mapred's FileAlreadyExistsException was deprecated with MAPREDUCE-963 but later on it
was un-deprecate with MAPREDUCE-1735/MAPREDUCE-3771 accidentally.
> It think it was un-deprecate by mistake:
> # MAPREDUCE-963 deprecate FAEE
> # Later on the whole Mapreduce 1 API was deprecated
> # By MAPREDUCE-1735/MAPREDUCE-3771 Mapred 1 API (including FAEE) was un-deprecated.
> Since FAEE was deprecated regardless of point 2 it shouldn't have been un-deprecated.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: mapreduce-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: mapreduce-issues-help@hadoop.apache.org


Mime
View raw message